Versioning

The Sandbox API is currently in major version 3.4.0. Whenever we make a backwards-incompatible change to a general availability, we release a new API version to avoid causing breakages for existing developers. You can then continue to use the old API version, or update your application to upgrade to the new Sandbox API version. All features which are not backwards compatible will be pushed as a major version release. Features that we consider to be backwards compatible include the following:

  • Adding new API resources.

  • Adding new 'required' input params to existing API methods.

  • Adding new attributes to existing API responses.

  • Changing the order of attributes in existing API responses.

  • Changing the length or format of objects

All requests will use this default setting unless you override the API version. By specifying a version in a REST request, you can get expected responses regardless of future changes to the API. You can also manually set the X-Api-Version header to use a specific version for a given API request.

Sandbox will communicate the creation of any new version as well as any deprecation of older versions